Connectivity Issues
Incident Report for channel PEAR
Resolved
This incident has been resolved.
Posted May 22, 2018 - 14:59 PDT
Investigating
Our servers are experiencing intermittent connectivity problems. We are investigating the problem.
Posted May 22, 2018 - 13:40 PDT
This incident affected: Website, Devices, and API.