Premium subscription
Incident Report for channel PEAR
Resolved
New payment features have been implemented.
Posted Feb 22, 2017 - 03:06 PST
Identified
We're currently integrating new features to our existing premium subscription payments system. During this time new members will be unable to purchase a premium subscription. Members that already have a premium subscription are not impacted.
Posted Feb 17, 2017 - 09:15 PST